1

1.1 資料、資訊與資料處理

n 資料（data）或原始資料（raw data）：一些未經過處理的文字、數字或符號，例如物件的顏色或重量、今天的天氣狀況、問卷內容等。

n 資訊（information）：資料經過處理後所得到有意義的知識或信息，可作為決策或行動的參考或依據，例如產品重量的平均值、一組相關的天氣狀況、對問卷內容的分析等。

n 資料處理（data processing）：利用人工或機械處理或分析資料的過程，如分類、轉換、計算、統計、分析、排序等。資料處理可分為三個步驟：輸入（input）、處理（process）、輸出 （output）。而資料經處理後所得到的資訊又可作為其他系統的資料，再產生其他資訊，此過程稱為資料處理循環。


1

1.2 資料處理的演進

n 人工式資料處理

l 完全以人工為主。

l 成本低、速度慢、準確性低。

l 輔助工具：紙、筆、尺子、算盤。

n 機械式資料處理

l 倚賴機器。

l 輔助工具：打字機、收銀機。

n 電子資料處理（electronic data processing, EDP）

l 利用電腦進行資料處理。

l 處理速度快，準確性高。

l 具有儲存及處理大量資料的能力。

l 輔助工具：電腦。


活動一︰

請舉出三個典型例子，說明在日常生活中，電腦可以怎樣協助我們工作。


1

1.3 何謂電腦

電腦（computer）一般是指通用電腦（general purpose computer），即我們常見的電腦系統。電腦又可解作處理器（processor），此一解釋常用於一些“電腦控制”的產品上。例如“電腦控制微波爐”並不是將電腦系統連接到微波爐，使前者能控制後者，而是指微波爐內置特別的處理器。此類處理器亦常被稱為嵌入式電腦（embedded computer）或特殊用途電腦（special purpose computer）。

處理器是所有電腦系統的核心，其結構包括記憶、控制及算術／邏輯運算三大單元。因為受生產技術限制，早期的處理器設計並非把這三大單元設置在同一塊晶片（IC chip）上。但隨着科技發展，現今的處理器一般都把這三大單元裝置在同一塊晶片上，因此亦被稱作中央處理器（central processor）或中央處理單元（central processing unit, CPU）。

除了中央處理單元外，電腦系統還包括輸入單元和輸出單元。一般的電腦基本架構如下：

電腦基本架構


活動二︰

要理解電腦如何運作，可把它與人類的身體及行為作比較︰

功能 | 人體 | 電腦
1. 輸入功能 |  |
2. 記憶功能 |  |
3. 運算功能 |  |
4. 控制功能 |  |
5. 輸出功能 |  |


1

1.4 電腦的特質

一般來說，電腦具備四大特質：

n 運算處理速度快；

n 準確性及精確度高；

n 儲存容量大；

n 具傳輸能力。

此外電腦還可以處理文字、符號和圖像，並且能夠提供資料安全的保護。


1

1.5 電腦分類

電腦的發展非常迅速，令電腦的分類十分模糊，但傳統上可分為四大類：

n 微型電腦（microcomputer）；

n 迷你電腦（minicomputer）；

n 大型電腦（mainframe）；

n 超級電腦（supercomputer）。


1

1.5.1 微型電腦

微型電腦的設計比較簡單，一般只有一枚CPU，因此價格比較平，適合一般個人使用，如：文書處理、報表處理、多媒體娛樂、遊戲等。隨着CPU的功能日益強大，現今微型電腦也可當作伺服器（server）使用。

微型電腦家族的成員十分多，包括桌面電腦（desktop）、手提電腦（laptop）和平板電腦 (Tablet PC)。


1

1.5.2 迷你電腦

迷你電腦比微型電腦複雜，一般的設計多為兩至四枚CPU，因此價格亦較微型電腦昂貴。其外型和桌面電腦沒大分別，但運算功能則較為強大，通常用於工程或科研上的運算、複雜的圖像處理和設計、或用作網絡上的工作站（workstation）和伺服器。由於微型電腦的功能不斷提升，且價格不斷下降，迷你電腦已較少被採用。


1

1.5.3 大型電腦

大型電腦的設計非常複雜，但其運算功能亦十分強大，價格亦非常昂貴。一般用於處理大量的資料，如銀行、證券交易所等企業的資料處理。早期的大型電腦的體積有如一個房間，現在則像雪櫃般大小。使用者通常看不到大型電腦，而是透過終端機（螢幕與鍵盤的組合）存取大型電腦內的資料。

IBM S/390 系列大型電腦


1

1.5.4 超級電腦

超級電腦的設計極為複雜，運算功能亦極之強大。當然其價格亦極之昂貴。與大型電腦不同，超級電腦多數是因應特殊需要而設計，大多用於科學上或軍事上的研究，或氣象的預測，例如：Cray MTA、IBM RS/6000 SP等。

前五名速度最快的超級電腦（截至2005年六月止）：

裝造商

超級電腦名稱

安放地點

IBM

BlueGene/L

Lawrence Livermore National Laboratory (美國)

IBM

BGW

IBM Thomas J. Watson Research Center (美國)

SGI

Columbia

NASA Ames Research Center (美國)

NEC

Earth Simulator

The Earth Simulator Center (日本)

IBM

MareNostrum

Barcelona Supercomputer Center (西班牙)

如有興趣知道現今世界上最快500台超級電腦的排名，可瀏覽以下網址：http://www.top500.org/


1

1.5.5 其他類型的電腦

因應時代變遷，電腦產品變得五花八門。傳統的分類難以適用於一些新型電腦，如：個人數碼助理、網絡電腦、智慧型手機等。


1

1.5.5.1個人數碼助理（personal digital assistant, PDA）

個人數碼助理是一種以手寫輸入、觸控式螢幕、語音辨識等方式輸入資料的掌上型電腦（Palmtop）。其體積細小，可放進口袋。而且價格較低，並支援無線通訊，適用於個人資料管理。

Palm PocketPC


1

1.5.5.2 網絡電腦（network computer, NC）

網絡電腦是一種因應互聯網的流行而出現的產品。它具備處理器和少量記憶體，主要是用於連接到具特別功能的電視（WebTV），讓使用者透過電視上網。


1

1.5.5.3 智慧型手機（smartphone）

智慧型手機可看作是傳統手機與個人數碼助理的混合體。除了作為一般手機使用之外，還能在手機上隨時隨地觀看新聞、電影、MTV，欣賞MP3和各種線上音樂，瀏覽網頁和玩各種刺激的線上遊戲並可進行線上聊天等。

Dopod 575 智慧型手機 PalmOne Treo 650智慧型手機

現時市場上可供智慧型手機使用的作業系統有以下四種：

1. Symbian作業系統

2. MS Windows Mobile

3. Linux作業系統

4. Palm作業系統


超小型電腦

1.5.5.4 超小型電腦（Ultra Mobile PC, UMPC）

超小型電腦（UMPC）是由Microsoft及Intel合作推出的新類型電腦，目的在於為電腦用戶提供一個理想的流動工作及娛樂平台。超小型電腦的大小介乎於筆記簿型電腦（notebook computer）與個人數碼助理（PDA）之間，重量小於1Kg；配備有7吋輕觸式顯示螢幕（解像度不低於800 x 480點），內建IEEE802.11b/g無線網絡及藍芽功能，並採用Windows XP Tablet PC Edition 2005作業系統。雖然UMPC己推出市面一段時間，但銷路只是一般，主要原因相信是：其電池使用時間有限（只有3 ~ 4小時）及售價過高（由 $7,000 至 $17,800不等）。不過在生產商的努力下，這些問題日後定有解決的方法。

Sony VAIO UX90超小型電腦


活動三︰

試根據下列要求，建議使用合適的電腦。

1) 記錄每天的行事曆

2) 處理一般文書

3) 模擬核爆

4) 玩網上遊戲

5) 銀行處理交易資料

6) 預備演講資料

7) 處理複雜的圖像


2

2. 硬件

軟件和硬件是電腦系統的兩大基本元素。軟件是一些資料性的物件，例如：文字、歌曲、圖像、程式等等。而硬件是指一些實質性，可觸摸到的物件，例如：螢幕、打印機等等。


2

2.1 系統單元（System Unit）

電腦的系統單元是指位於機箱內的元件，包括母板（motherboard）、中央處理器（CPU）和主記憶體（main memory）。


2

2.1.1 母板

母板是電腦裏最重要的基礎元件，它是一張大面積的電路板，各種電腦零件，
如：中央處理器、主記憶體、介面卡及磁碟機，都要連接或安插在母板上，才能互相交換資料，
使電腦正常運作。
由此可見，母板很大程度上決定了一台電腦的效能、穩定性及擴充能力。

不同的母板會支援不同種類的中央處理器（例如：Intel Celeron D、Intel Pentium 4、AMD Sempron、AMD Athlon 64），

所以購買母板時，必須留意母板是否能配合你選用的中央處理器。


2

2.1.2 中央處理器 (CPU)

CPU的結構大致如前述的電腦基本架構圖內所示中央的三部分。它主要負責算術運算、邏輯運算和程式執行。中央處理器的速度是指內部處理指令的頻率，亦稱為“內頻”，單位是GHz。內頻愈高，表示處理速度愈快。例如：

CPU

內頻

AMD Athlon 64 X2

2 ~ 3GHz

Intel Core 2 Duo

1.6 ~ 2.66GHz

暫存器(Register)

  • CPU內的記憶單元稱為“暫存器”。

  • 暫存器用作暫時存放CPU目前正在進行運算和剛運算完的資料。

  • 暫存器是記憶體中速度最快的，但製造成本十分高，因此容量卻是最小的。

雙核心CPU

雖然可增加CPU的內頻來提升CPU的效能，但同時導致CPU發熱量大增。為了進一步提升CPU的效能，近年製造商推出雙核心甚至是多核心的CPU。雙核心處理器就是將兩顆處理器做在同一塊晶片上（即是把兩個CPU放進一個CPU封裝裡）。理論上，雙核心處理器的性能比單核心處理器可高出50%—70%。

CPU

內部快取記憶體

零售價（於2007年7月）

AMD Athlon 64 3200+ (單核心)

512KB

HK$430

AMD Athlon 64 X2 5600+ (雙核心)

2048KB

HK$1,430

Intel Celeron D 440 (單核心)

512KB

HK$493

Intel Core 2 Duo E6700 (雙核心)

4096KB

HK$2,500

快取記憶體（cache memory）

  • 為了解決高速的中央處理器和緩慢的主記憶體間的通訊問題，現今的電腦系統大多 設置快取記憶體（cache memory），用以存放一些暫存器可能即將使用的資料，有緩衝作用。

  • 快取記憶體亦分為內部快取記憶體（L1 cache, internal cache）和外部快取記憶體（L2 cache, external cache）。

  • 以往L1 cache是設置於中央處理器內，而L2 cache則以獨立晶片的形式安插在母板上。但現在L2 cache已經改為內置在中央處理器內。


2

2.1.3 主記憶體

主記憶體是以超大型集成電路（very large scale integration, VLSI）製成的半導體元件，可分為隨機存取記憶體（random access memory, RAM）和唯讀記憶體（read only memory, ROM）兩種。

RAM

ROM

特性

1. 除了供讀取資料之用，還可以寫入資料

2. 當電源關閉後，所儲存的資料隨即消失，屬於揮發性的記憶儲存體

1. 僅供讀取資料之用，而不能寫入資料

2. 當電源關閉後，所儲存的資料不會消失，屬於非揮發性的記憶儲存體

用途

主要用來存放電腦中要執行的程式或資料

主要用來存放開機程式，如：基本輸入／輸出系統（Basic Input/Output System, BIOS）

主記憶體 (RAM)

快閃記憶體（flash memory）是一種以嶄新技術製成的半導體。可以視為可寫入資料的ROM，具有RAM 及ROM的優點。目前很多新型的電腦系統都以快閃記憶體儲存BIOS，其好處是可以更新BIOS的版本。除此之外，快閃記憶體還廣泛應用於數碼相機、MP3、錄音筆等產品。


2

2.2 週邊設備（peripheral）

週邊設備是系統單元以外的硬件。使用者可透過週邊設備和電腦相互溝通。周邊設備大致可分為4種類型：

n 輸入設備：將資料、程式或命令傳送到電腦內部的設備。

n 輸出設備：將電腦執行的結果以文字、數字、圖形或聲音等方式輸出的設備。

n 存取設備：用來存儲程式和資料，通常具有輸入及輸出設備的特性。

n 通訊設備：在網絡連線系統中，用來將資料傳送給其他電腦，或接收其他電腦
資料的設備。


2

2.2.1.1 鍵盤（keyboard）

鍵盤是最常見的輸入設備，主要功能是使用戶能直接鍵入文字及指令，與電腦溝通。

除了普通的有線鍵盤外，電腦用戶還可選擇使用無線鍵盤。現時市場上的無線鍵盤一般是使用無線電技術或紅外線作為無線傳送。


2

2.2.1.2 指向裝置（pointing device）

指向裝置是藉由控制螢幕上的指標來完成輸入、執行、繪圖、拖曳、搬移等動作。指向裝置的種類五花八門，常見的有滑鼠（mouse）、軌跡球（trackball）、手寫板（writing pad）、遊戲搖桿（joystick）、觸控板（touchpad）、觸控式螢幕（touch screen）等等。


2

2.2.1.4 掃描器（scanner）

掃描器的主要功能是將紙上的圖像（包括文字及一切圖案）作數位化處理，轉換成為能供電腦編輯及存案的格式。現今大多數的掃描器都附設文字辨識／光學字元辨析（optical character recognition, OCR）功能的軟件。


2

2.2.1.5 麥克風（microphone）

麥克風把聲音轉變為電流訊號後，再把它傳送到電腦裏，這樣我們就可以把聲音錄下來了。


2

2.2.1.6 條碼閱讀機（barcode reader）

條碼（barcode）是一組由粗幼和／或間距不同的線條所組成的編碼。條碼常用於產品辨識和圖書編碼上。條碼閱讀機能將條碼上的資料輸入電腦。


2

2.2.1.7 生物特徵辨識裝置 (biometric device)

生物辨識（biometrics）是指利用人類獨有的生理特徵（例如：指紋、面貌、掌形、聲紋、瞳孔、簽名等）作為辨識及確認其真實身份。生物特徵辨識裝置主要功用是把這些生理特徵數碼化，然後輸入到電腦內。現時常見的生物特徵辨識裝置有指紋辨識器、掌形辨識機、瞳孔掃描器、語音辨識系統等。


2

2.2.1.8 其他輸入設備

除了上述設備外，輸入設備還有光學記號辨識（optical mark recognition, OMR）、光學字元辨識（optical character recognition, OCR）、磁性墨水字元辨識（magnetic-ink character recognition, MICR）、智慧卡閱讀機（smart card reader）等等。


2

2.2.2.1 顯示器（monitor）

顯示器亦稱為“螢幕”，可分為CRT及LCD兩種類型。CRT顯示器一般由三支紅、綠、藍三原色的電子管組成，故體積較大。

LCD顯示器一般耗電及產生的輻射較少，體積亦較小。

顯示器的質素主要取決於“點距”（dot pitch）。點距是指顯示器上每光點之間的距離，點距愈少，圖像愈細緻。市面上一般的顯示器的點距是0.28mm，若要求更高品質，可選購點距0.24mm的顯示器。

選購LCD 顯示器時，須留意以下幾點：

n 尺寸大小（一般由15寸至19寸）

n 對比度（e.g. 450:1）

n 光度（e.g. 250cd/m2）

n 反應時間（e.g. 12mS）

n 最高解像度（e.g. 1280 x 1024）

n 有沒有“死點”和“光點”

n 輸入介面（e.g. VGA input, DVI input）


印表機又稱為

2.2.2 .2 印表機（printer）

印表機又稱為“打印機”或“列印機”。

印表機種類：

印表機可以分為“撞擊式”和“非撞擊式”兩類。

  • 撞擊式印表機利用機械式敲擊色帶以印出圖文，因此列印速度較慢，發出的聲音較大，典型代表有點陣式（dot matrix）印表機。

  • 非撞擊式印表機利用噴墨、熱力或壓力印出圖文，無須撞擊紙張，因此列印速度較快和較靜，典型代表有噴墨式（inkjet）和雷射式（laser）印表機。

列印速度

印表機的速度單位可分為：

  • ppm（page per minute），即每分鐘列印的紙張數量；

  • cps（character per second）即每秒鐘可印出的英文字母數量。

  • 鐳射式印表機多以ppm表示速度，而噴墨式和點陣式則兩種速度單位皆有應用。

列印品質

印表機的列印品質是dpi（dot per inch），即每英吋內可以印出的點數。

點陣式印表機（Dot Matrix Printer）

點陣機以針敲打色帶，將油墨打在紙上以達致列印效果，分為九針及二十四針兩種。九針機的速度較高，但效果較粗糙；二十四針機稍貴，但效果較理想。現多用於會計方面，以打印覆印紙單據。

點陣式印表機

鐳射式印表機（Laser Printer）

鐳射機以激光將碳粉固定於紙張上，列印效果極佳，一般速度由12至25 ppm，解像度由600至1200 dpi。一般鐳射式印表機只可列印黑白圖文，而彩色鐳射式印表機則極之昂貴。

鐳射式印表機

噴墨式印表機 （Inkjet Printer）

噴墨機以靜電將墨汁噴在紙上，列印效果遠比針機理想，解像度一般由360至2880 dpi，適合作彩色列印，甚至列印相片。噴墨式的最大缺點是不能像針機一樣打印覆印紙；另一缺點是印在紙上的墨水沾水時會產生毛細管作用，容易化開。

噴墨式印表機


2

2.2.2 .3 揚聲器（speaker）

揚聲器是提供音訊輸出的設備，主要是作為多媒體的輔助輸出，提供娛樂之用，但也是供給盲人的主要輸出設備。

揚聲器


活動四︰

請在下列表格內填上適當答案。

 | 點陣式印表機 | 噴墨式印表機 | 鐳射式印表機
打印速度 |  |  |
售價 |  |  |
優點 |  |  |
缺點 |  |  |


2

2.2.3 存取設備

存取設備又稱為“輔助儲存設備”或“次級儲存設備”，用作存放資料和程式。存取設備和主記憶體不同。主記憶體是揮發性的（當電源關閉後，所儲存的資料隨即消失）；而存取設備則是非揮發性的（即使電源關閉後，所儲存的資料不會消失）。其次，主記憶體的存取速度較快、價錢較貴、容量較小；而存取設備的存取速度較慢、價錢較平、容量較大。


2

2.2.3.1 軟式磁碟機（floppy disk）

軟式磁碟機簡稱“軟碟”，包含軟碟片（diskette）和軟碟機（floppy disk drive）兩個部分。軟碟片是儲存的媒體，而軟碟機則是用來讀寫軟碟片的裝置。軟碟的容量細小（1.44MB）、存取速度慢，但有隨意抽取、攜帶方便的優點。


2

2.2.3.2 硬式磁碟機（hard disk）

硬式磁碟機簡稱“硬碟”。和軟式磁碟機不同，硬式磁碟機的碟片裝置在磁碟機內，不能隨意抽取，因此不方便攜帶。硬式磁碟機通常是安裝在電腦機箱內。硬式磁碟機的優點是存取速度快、容量大。現時硬式磁碟機的容量一般由80GB至500GB不等。購買硬式磁碟機時，除容量外，還要留意所採用的介面類型（Serial ATA、Parallel ATA或SCSI）及緩衝記憶體（buffer）的大小（一般由2MB至16MB不等）。


2

2.2.3.3 高容量磁碟（high capacity disk）

高容量磁碟的外觀和軟碟十分相似，攜帶亦非常方便。其速度和容量均介於軟碟和硬碟之間。常見的高容量磁碟有SONY推出的HiFD，容量為200MB；Imation推出的SuperDisk，容量為120MB、240MB，故又稱為LS120、LS240；Iomega推出的ZIP，容量為100MB、250MB、750MB。

ZIP Drive and Diskette


2

2.2.3.4 光學儲存設備（optical storage）

前面所介紹的儲存設備均屬於磁性儲存設備（magnetic storage），資料是以不同的磁極儲存於帶磁性的媒體上。而光學儲存設備則靠光碟片上的凹槽來定義資料，經過雷射光速的反射來讀取。常見的光學儲存設備有VCD、CD-ROM、CD-R、CD-RW、DVD-ROM、DVD-RAM、DVD-R、DVD-R/W、DVD+R、DVD+R/W。

光碟類型

CD-ROM

CD-R

CD-RW

DVD-ROM

DVD±R

DVD±RW

資料容量

650MB至700MB

650MB至700MB

650MB至700MB

4.7GB至8.5GB

4.7GB至8.5GB

4.7GB至8.5GB

可寫入

否

可

可

否

可

可

讀寫方式

唯讀

只可寫入一次

可重覆寫入

唯讀

只可寫入一次

可重覆寫入

價錢

不適用

最平

中等

不適用

貴

最貴

不同光碟制式的分別

除以上制式外，還有最新的HD-DVD 及 Blue-ray 制式，兩者的容量分別如下：

光碟類型

HD-DVD

Blue-ray

資料容量

單面15GB

雙面30GB

單面25GB

雙面50GB


2

2.2.3.5 其他儲存裝置

在很多情況下，例如處理圖片、數據備份等，都佔用很大的儲存空間。於是市面上陸續出現了多種不同設計及格式的儲存設備，例如：USB Drive、Memory Stick、Smart Media、PC Card、Smart Card等等。


2

2.2.4.1 數據機（MODEM）

數據機是供電腦經電話系統互傳資訊的設備，可分為內置式及外置式兩種。其操作原理是當輸出資料時出把電腦的數碼訊號轉換成電話線路的訊號，然後將資料傳送，而接收時則把電話線路的訊號轉換成電腦的數碼訊號。資料傳送的量度單位，是以每秒傳送的位元數計算（bps, bit per second）。現時市面上一般的數據機的傳送速度為每秒56000 bits (即是56Kbps)。


2

2.2.4.2 網絡卡（Network Interface Card, NIC）

網絡卡是供網絡上的電腦互相直接傳送資訊的設備。資料傳送的速度比數據機快數百倍以上。現時市面上常見的是Ethernet 10/100網絡卡，10/100表示速度，每秒的傳輸資料速度最高達100 Mbits。


2

2.3 擴充卡（expansion card）

擴充卡是連接母板和週邊設備的介面，因此又稱“介面卡”。但因應需要，一些所謂“一體成型”（all-in-one）的母板已將大部分的擴充卡直接裝在母板上。現時最常見的擴充卡有顯示卡（display card）和聲效卡（sound card）。


2

2.3.1 顯示卡

顯示卡的主要功能是把電腦產生的電子訊號，轉換成顯示器可接收的視訊訊號。現在使用的顯示卡是以彩色顯示及能支援3D影像處理。因此，顯示卡功能的主要分別在於顯示顏色的多寡及處理3D影像的能力。

若每一個像素訊號以四個位元來記錄，就能產生24 =16種組合，即能顯示16種顏色。24位元全彩已足夠顯示生活中全部的色彩。

顯示卡的記憶體

市面上一般的顯示卡基本上都配備64MB記憶體。記憶體的多少，不會影響顯示速度，但會影響所能顯示顏色的數量。舉例來說，1MB記憶體在640 × 480的解析度上，可顯示全彩顏色，但若使用1024 × 768解析度，則只能顯示256色。


2

2.3.2 聲效卡（sound card）

現時的電腦趨向多媒體發展，自然追求高度傳真的音響效果，若要在電腦上播放鐳射唱片、動畫光碟，就必須倚賴聲效卡及外置的揚聲器了。


2

2.4 擴充插槽和輸入／輸出埠

擴充插槽（expansion slot）和輸入／輸出埠（input/output port）是設置在母板上的連接口。擴充插槽是用以接駁各樣的擴充卡，而輸入／輸出埠則是用以直接連接各樣的週邊設備。常用的輸入／輸出埠有串列埠（COM 1 & 2）、平行埠（Parallel）、通用串列埠（USB）、遊戲搖桿埠（Game Port）、數碼樂器埠（Music Instrument Digital Interface, MIDI）、IEEE 1394（又稱為FireWire）等等。

輸入／輸出埠

一般接駁的週邊設備

COM port

Mouse, External Modem, 手寫板

Parallel port

Printer, Scanner

PS/2 port

Mouse

USB port

Mouse, Keyboard, Printer, Scanner, Webcam

Portable MP3 player, Digital Camera,
TV Box, External Hard Disk Case

Game port

Joystick

MIDI port

數碼音響器材

IEEE 1394 / FireWire

Scanner, Digital Video


2

2.5.1 電源供應器

電源供應器的主要功能是提供穩定的電源給母板和磁碟機等周邊設備使用。電源供應器的大小常以它的功率為量度標準，單位為瓦數(watt)，一般常見的大多為200至500瓦(W)的功率。此外，電源供應器還包括負載保護的功能，可避免短路所帶來的危險。現今CPU及顯示卡的耗電量驚人，宜選購一台至少有350W的電源供應器。


2

2.5.2 電腦機箱

一般個人電腦系統的母板、電源供應器 （power supply）、軟／硬式磁碟機、光碟機（CD-ROM）、介面卡、記憶體（memory）和中央處理器等，都是裝置在一個金屬外殼內，該外殼稱為機箱（computer case），通常簡稱為case，目的是保護重要的電腦零件及令用戶易於安放整套電腦系統。


活動五

試從香港高登網站（＜http://www.hkgolden.com＞）及Centralfield Computer Ltd.網站（＜http://www.centralfield.com.hk＞），找出一套個人電腦應有的設備及價錢。另外，請以小組形式討論時下最流行電腦產品的品牌、型號、性能和市場價格，藉以提高對電腦市場的觸覺及興趣。

裝置 | 型號 | 規格 | 價錢(HK$) | 選購原因
電腦母板 (主機板) | ASUSTek P5B | ATX / SOCKET775 / PCIex16 | 850 | 價錢經濟，多人使用。
處理器 (CPU) |  |  |  |
光碟燒錄機 (DVD-R/W) |  |  |  |
硬碟機 (Hard Disk) |  |  |  |
記憶體 (RAM) |  |  |  |
顯示卡 (Display Card) |  |  |  |
顯示器 (Monitor) |  |  |  |
聲效卡 (Sound Card) |  |  |  |
揚聲器 (Speaker) |  |  |  |
電源供應器 (Power Supply) |  |  |  |
電腦機箱 (Case) |  |  |  |
其他: |  |  |  |
 |  |  | 總計 |

選擇電腦設備指引

處理器 CPU | 型號越高，暫貯記憶越多，處理速度及性能越高，價錢越貴。
記憶體 RAM | RAM(MB)越多，電腦運作速度越快。
主機板 Mother Board | 留意 CPU插座是否適合您的CPU；擴充性(槽的數目)。
顯示卡 Display Card | 介面型號越高，傅送影像速度越快；記憶體越多，處理影像能力越好。
顯示器 Monitor | 留意螢幕尺吋、CRT/LCD、解釋度、價錢。
硬碟 Hard Disk | 留意容量(GB)、轉速(RPM)、緩衝記憶(KB)及搜尋時間(ms)。
光碟機 DVD/CDRW | 留意速度(x)。
噴墨打印機 Inkjet Printer | 留意彩色印速(ppm)、解像度。
雷射打印機 Laser Printer | 留意印速(ppm)及緩衝記憶的多少。
掃描器 Scanner | 留意解像度及色深(bit)。


3

3. 軟件

軟件是一些資料性的物件，是由程式及資料所組成，用以指揮電腦解決帶有特定問題的一連串指令。程式在電腦上執行，它告訴電腦硬件如何處理資料。

基本上，軟件大致分為兩大類：

n 系統軟件（System Software）

n 應用程式軟件（Application Software）


3

3.1 系統軟件

系統軟件是軟體系統的核心，也是與硬體溝通的橋樑，它用來協助其他程式執行指令，通常由電腦廠商發展並提供給使用者使用，也有兼容選購的。

系統軟件的主要目的在於管理電腦資源和運作，令程式間配合無間，從而提高電腦的運作效能。

系統軟件亦分為：

n 作業系統（operating system）

n 電腦語言處理程式（computer language）

n 公用／工具程式（utility）

n 驅動程式（driver）


3

3.1.1作業系統

作業系統是應用程式軟件與硬件間的介面，用以分配電腦系統資源，監督電腦作業。例如 MS Windows、MacOS、UNIX、Linux 等等。

作業系統是一種系統程式，功能有如一個保護殼，把使用者與電腦分隔開。

使用者每次執行應用程式前，必須先載入作業系統，作業系統成了應用程式與硬件之間的橋樑。

簡單來說，應用程式“告訴”電腦如何去完成工作，而作業系統則“控制”電腦怎樣去完成工作。

下圖展示使用者、應用程式、系統程式與電腦硬件之間的關係。

使用者(使用電腦的人)

應用程式(例如MS Word)

系統程式(例如 WindowsXP)

電腦硬件


活動六︰

試解釋作業系統如何在電腦系統中扮演“管家”的角色。


3

3.1.2電腦語言處理程式

電腦語言處理程式是供給程式編寫員開發各類軟件之用。

各種電腦語言處理程式都有自己特定的指令及語法，

用以描述解決問題的方法和步驟，稱作電腦語言。


3

3.1.2.1 低階語言

低階語言是最早期出現的電腦語言，包括機械語言和組合語言。低階語言是針對CPU作出直接的操控，因此一般以低階語言所編寫的軟件的執行速度比較快，但編寫程序難度高，可讀性低，相容性差。

機械語言（machine language）：

à 以“0”和“1”的組合來表示指令或資料。

à 不同的電腦有不同的機械語言。

組合語言（assembly）：

à 用一些有意義的英文字母及符號，例如：MOV、 ADD等代替“0” 和“1”的組合。組合語言需要利用組編程式（assembler）來轉換。

à 稍稍改善了編寫程序的難度和可讀性。


3

3.1.2.2 高階語言

高階語言的指令和語法較為接近日常語言，因此更易閱讀、編寫和修改，使軟件的開發速度大為提高，但其編寫的軟件的執行速度一般比較慢。高階語言所編寫的軟件需要利用翻譯程式（complier／interpreter）來轉換成可執行程式，其語法不受電腦平台和硬件型號影響，因此相容性高。

第三代語言（3GL）：

à 稱為結構性電腦語言，其語法描述如何執行工作讓電腦跟從。

à 例如 BASIC、C、Pascal、Fortran、COBOL等。

第四代語言（4GL）

à 擬定一組推理規則與語法，再由電腦自行尋找最佳解決途徑。

à 優點是可縮短撰寫程式的時間，但執行效率較差，需較多電腦資源來執行工作。

à 例如SQL。

第五代語言（5GL）

à 將人類的自然語言轉換成程式碼，希望完全不受語法的限制。通常用於“知識庫系統”（Knowledge Base System） 及“資料庫擷取”（Data Mining）上。

à 例如 Prolog。

物件導向編程語言（object-oriented programming language）

à 任何東西都是物件。將問題化作一群物件，設定他們的屬性和功能，再模擬物件之間的信息交流，直至解決問題為止。速度最慢，但較易理解及修正。

à 例如 C++、SmallTalk、Java、Visual Basic、Delphi等。


3

3.1.3公用／工具程式

公用／工具程式提供一些次要的服務程式，以補充作業系統的不足或個別使用者的需要。例如病毒檢查、影像檢視程式、畫面摘取程式等。


3

3.1.4驅動程式

驅動程式是周邊設備的操控程式，電腦必須透過驅動程式與周邊設備溝通。現今的作業系統，如Window XP，都附設部分常用的驅動程式。


3

3.2 應用程式軟件

應用程式軟件是因應使用者的不同需要而開發的，幫助使用者解決各種特定的事務或工作上的問題。


3

3.2.1 軟件的使用權

所有新的發明，包括新開發的軟件，其開發者都擁有其版權。軟件的開發往往需要投入大量的資源。為了獲得補償，開發者往往以收費方式將軟件發售並付予軟件使用者使用權，但也有個別開發者不向使用者收取使用者費用。按不同的使用權限和收費原則，軟件可分為：

n 商業套裝軟件

l 使用者必須依照使用者付款的原則以取得軟件使用權。它受到知識產權的保護，使用者不可隨意複製給他人使用。例如MS Office、Corel Draw等。

l 由組織完備的公司負責開發軟件，這類產品的包裝很精美，以吸引消費者購買，並有完善的售後服務。

n 開放原始碼軟件

l 使用者或程式開發人員可免費取得軟件的原始碼（Source Code），因原始碼開放，任何人都可以了解該軟件的內部運作原理。這樣軟件不但可因應使用者的需要而修改，漏洞更能夠很快被發現與處理。例子包括Linux作業系統、Apache 網頁伺服器、sendmail郵件伺服器等。

l 開放原始碼軟件的定義：

- 軟體散佈給他人時不得附加任何限制

- 必須開放原始碼，好讓使用者可加以改善

- 修改後的軟體不得再與原本軟體採用同一名稱或版本編號

n 免費軟件

l 源於有創造慾的網絡使用者，他們撰寫小型公用程式來解決使用電腦時遇到的問題，並在網絡上發表，免費供人下載。也有軟件公司為提高知名度，提供免費的簡化版。例如PowerDesk、Ad-aware、WS_FTP LE等。

l 一些程式漸漸地受到廣大使用者支持，促使愈來愈多人投入開發，而發表程式種類也擴展到應用程式，將來可能會朝向共享軟件或商業軟件發展。

n 共享軟件

l 通常透過網絡發行，容易取得。這些軟件雖可以免費取得，但卻非全然免費，使用者用後如覺得滿意，必須向原作者付費註冊，未註冊版本通常會有使用期限或功能不齊的限制。例如WinZip、ACDSee等。

l 共享軟件的開發人員通常比較少，所以多屬於功能比較簡單的軟體，不過透過網絡行銷，可節省許多廣告和包裝費用。


3

3.2.2 功能分類

軟件除了可依據使用權限和收費原則來分類外，還可以依據功能來分類。一般的功能分類如下：

n 商業／生產性（business / productive）

n 文檔製作：文書處理、桌上排版、網頁編輯

n 數值運算：電子試算表、會計財務、統計分析

n 簡報、客戶關係管理

n 資料庫、企業資源策劃

n 繪圖、影像處理、多媒體編輯

n 網絡通訊：瀏覽、資料蒐集、電郵、檔案傳輸、交談、遙控等

n 學習／訓練（learning / training）

l 字典、百科全書

l 電腦輔助教學

n 娛樂（entertainment）

l 遊戲

l 多媒體播放


活動七︰

試描述“系統程式”與“應用程式”在功能上的分別。


4

4.1 何謂知識產權？

知識產權 （intellectual property） 泛指一組無形的獨立財產權利，包括商標權、專利權、版權、外觀設計權、植物品種保護權及集成電路的布圖設計權。知識產權對於我們的日常生活十分重要：衣物的品牌、報章上的文章、電視節目、流行歌曲、電影及時裝設計等等，均與知識產權息息相關。


4

4.2 保護知識產權為何這樣重要？

保護知識產權即保護人類的創意。我們需要保護作家、藝術家、設計師、軟件程式設計員、發明者及其他專才的心血，以期創造一個環境，讓上述人士可以盡情發揮創意，並讓辛勤的工作得到回報。

香港是個充滿創意的地方。本港的電影製作、電視製作、錄音製作、書刊、時裝以及珠寶和平面設計均名聞遐邇，廣受海外人士歡迎。香港又是國際商貿中心，我們有責任向在港的投資者提供所需的知識產權保護，確保他們可以在一個公平、自由的環境下營商。


4

4.3 保護知識產權保護什麼？

不是所有的意念、發明或創作都是得到保護的。例如：為了平衡產權人及社會的整體利益，一種藥物發明可受到專利註冊的保護，但用以治療某一項疾病的療法卻不然。另外，在未經同意的情況下把某一個卡通人物用於商品上是非法行為，但一個孩子把它繪畫下來卻沒有問題。


4

4.4 複製軟件是非法的嗎？

並不是因為你能複製軟件就算合法，電腦軟件與書籍和電影同樣受版權保護。版權是給予程式的作者或版權持有人某種獨佔權利的一種合法保護形式。版權持有人是唯一享有複製、發布、出售和更改內容等所有權利的人。

你購買了享有版權的軟件後，並不表示你已成為版權的持有人，你僅是獲得了使用這個軟件的權利。你可安裝使用，但不可以為了分發或出售而複製。

有關香港的版權法詳情可瀏覽以下網址：

< http://www.ipd.gov.hk/chi/home.htm >

< http://www.ipd.gov.hk/chi/faq/copyright.htm >


活動八︰

假如我們不是軟件的作者，可否：

l 製作備份軟件？

l 出售複製品？

l 把複製品送給朋友？


附錄一　記憶體儲存單位

課堂活動

1. 假設每首歌曲的大小是4MB，你的MP3機有20GB儲存量，試計出你的MP3機最多可儲存多少首歌曲?

答案：20GB / 4MB = (20*1024)MB / 4MB = 5,120歌曲

2. 一隻1.44MB的軟磁碟，最多可儲存多少個英文字母?

答案：1.44MB / 1B = (1.44 * 1024 *1024)B / 1B = 1,509,949字母

l 記憶體容量的單位：

1KB = 1024 Bytes = 210 Bytes ~ 103 Bytes

1MB = 1024 KB = 220 Bytes ~ 106 Bytes

1GB = 1024 MB = 230 Bytes ~ 109 Bytes

1TB = 1024 GB = 240 Bytes ~ 1012 Bytes

l 位元（bit）：電腦所能認識、儲存的基本單位，可用來儲存1個二進制的 0 或 1 。

l 位元組（byte）：

8 bits = 1 Byte = 1 character （例如“A”）

為何是 8 bits ? 因為0或1只能代表兩個意思，要代表全部英文字符、數字字符和一般符號字符等，最少需要百多個的組合，所以科學家利用了二進制的組合， 28 = 256個包容了所有基本字符。後來美國國家標準局訂立的資訊交換碼（ASCII）字符集，成為不同電腦之間資料傳輸的標準，例如︰00100001是代表“A”。

l 字組（word）：指電腦在執行運算時，一次所能處理的位元數，位元數愈大表示電腦的處理速度愈快。例如64位元的電腦，即表示 CPU到主記憶體以64 bit來存取資料，其字組長度即為64位元，共（或）8 bytes。


基本電腦及資訊科技概念

資訊科技（Information Technology, IT）泛指所有用來獲取資訊的科學方法及技術。由於電腦技術的發展迅速，以致被廣泛應用於資料處理，因此，資訊科技常被誤認為電腦應用。